суббота, 24 октября 2015 г.

FreeBSD upgrade. October 2015

Update the operating system

# freebsd-update fetch
# freebsd-update install
# shutdown -r now

Upgrade binary packages

# pkg update
# pkg updating | $PAGER
# pkg upgrade
# portupgrade -fr ffmpeg
# portupgrade -fr icu
# pkg autoremove
# pkg clean
# portsclean -C

Major improvements and bug fixes

MATE Desktop

[Bug 202984] x11/mate desktop version 1.10, Trash does not work has been fixed. May be accidentally? ;)

Implementing the patches

For gnome-mount

Patch

MATE still does not mount DVDs and SD cards because gnome-mount is still broken. Therefore I suggest to allow users to mount devices. To do this...
# cd /etc
# #   tune the kernel
# cp sysctl.conf sysctl.conf.orig
# echo 'vfs.usermount=1' >> sysctl.conf
#  we should use devfs.rules instead of devfs.conf
#  to be able to work with devices plugged in
#
  after the system is in multi user mode
# cp devfs.rules devfs.rules.orig
# echo 'add path 'da*'        mode 0660 group operator' >> devfs.rules
# shutdown -r now
Ensure that rules set is enabled in /etc/rc.conf. For example, when the /etc/devfs.rules has the next content
[system=10]
add path 'usb/*'    mode 0660 group operator
add path 'da*'        mode 0660 group operator
then the /etc/rc.conf must has the next line
devfs_system_ruleset="system"

For user


First approach
First time: create an mnt/ at your home
% mkdir -p ~/mnt
Every time:
To mount...
% mount_msdosfs /dev/da0s1 ~/mnt
Then you can find the card in the mnt/ subdirectory inside your home directory.
If you do not know the name of the card device:
Run the next command to find out all the devices you can plug in to your system
% camcontrol devlist
Tip: If device did not mount, you should try to mount it again.
To unmount...
% umount ~/mnt
:-D
In my case the problem was a typo in the PolicyKit.conf ))
But this approach to allow users to mount devices really works !

Bibliography 

  1. FreeBSD: Allow Normal Users To Mount CDROMs / DVDs / USB Devices. NixCraft (cyberciti.biz), http://www.cyberciti.biz/faq/freebsd-allow-ordinary-users-mount-cd-rom-dvds-usb-removabledevice/.
  2. devfs. FreeBSD (http://freebsdguide.ru), http://freebsdguide.ru/_8/_16/.



Комментариев нет:

Отправить комментарий